Realbasic - Programando para Linux, Windows y Mac desde Linux

Realbasic para principiantes.Editar

Introducción:

Esta es una versión modificada de el manual elaborado por Pelayo Casares, en su página puedes encontrar 17 lecciones sobre programación en Realbasic. Esta versión modificada del manual está hecho para trabajar con linux, pero funciona igual en mac y en windows.


Primera parte. - Conociendo RealBasic.

Primero debes instalar realbasic 2007 r5, se te pide que escribas un nombre y un email, luego te llega un email con tu nombre y contraseña para poder usar el programa por 30 dias, como es muestra los programas solo duran 11 dias, pero buscando en amule puedes hacerla permanente.

Se descarga el demo de este enlace: http://www.realbasic.com/download/

Algunos critican el lenguaje de programación basic, pero yo digo que es la mejor forma para comenzar, pues será por mi falta de conocimiento pero de todas formas está hecho hasta para niños de la escuela, incluso de kinder.

Porqué usar este programa?

Pues porque contruye programas para Linux, windows y mac con un solo código, evitando tener que volver a programar desde 0 para migrar tu programa (de pago o no) a otro sistema operativo, en otras palabras, los novatos haran lo que viejos de 80 años nunca han hecho de una forma tan fácil, digamos por no conocer este programa. De esta forma puedes pasar tus programas hechos en visualbasic a linux.




Primero instalas realbasic, cosa que no da ningún problema ya que esta hecho para ubuntu linux (aunque también para mac y windows).

Pues después de instalarlo abres el Realbasic. Siempre cuando se abre el realbasic se inicia el proyecto que consta de por lo menos dos componentes:

Ventana: window1 Menú: menubar1 Y un tercero que se llama App, que en este caso no lo tomaremos en cuenta.




Notas:

  • Al dar click en el botón "run" (ese botón verde), se corre el programa, en este caso una ventana vacia (fuera de realbasic), pues se podria llamar programa a esa ventana vacia, incluso puedes construir el programa, pero nosotros queremos un programa con funciones no una ventana vacia, solo fue para conocer como se ejecuta un programa dentro del proyecto.
  • Cierra esa ventana del programa que se abrió, volviendo a real basic...
  • La ventana es un elemento y tiene varias propiedades, las cuales puedes modificar, como su nombre, anchura, altura, etc.



Continuemos:

Estamos en Realbasic, en la pestaña Project, por ahora es la única.

Doble click a Window1 (Ventana1, debajo de App), y aparece la pestaña Window1, es la ventana de tu programa, donde aparece la ventana, a la cual le puedes cambiar las propiedades y agregar mas elementos.




Notas:

  • Dentro de esta ventana o pestaña, aparecen dos columnas:

- Una al lado derecho "las propiedades" de la ventana, las cuales puedes cambiar ya sea desde la ventana de propiedades o desde la ventana (digamos cambiando su altura, anchura, etc).

- Otra Al lado izquierdo aparecen otros elementos que se podrán agregar a la venta que también es un elemento.

- Enmedio la ventana que es lo que se muestra cuando abres el programa final, a donde colocaras todos los elementos y propiedades que quieras.




Puedes cambiar las propiedades de tu ventana:

  • Cambio del nombre del elemento (en este caso la ventana):

Por ejemplo en Id, name, está escrito Window1, puedes cambiarlo escribiendo en su lugar Ventana1, o tu nombre si prefieres.

Unicamente permite escribir usando letras y números, no se pueden dejar espacios ni símbolos. Para los espacios puedes usar el guión bajo, por ejemplo Tu_nombre. Así que ahora este elemento se llamará de otra forma (puedes verlo escrito arriba al lado de project y no en la ventanita de que está dentro del proyecto).

Pero en este caso lo llamaremos Ventana1

  • Cambio del título del elemento (en este caso la ventana):

También puedes cambiar el título de este elemento (el título es otra propiedad del elemnto, así como el ancho, el alto, etc.): Appearance, ves Tittle: Untitled, pues borras Untitled y escribes el nombre que prefieras, por ejemplo "Mi Ventana". En este caso como es un título (y no un nombrede elemento) puedes usar también símbolos y espacios.

Finalmente salvamos el proyecto: File, save as y escoges donde guardarlo y que nombre darle a este proyecto de programa. Por ejemplo: Tux.rbp, guardar.

Ahora cerremos realbasic, solo para ver como volver a abrir el proyecto.




Segunda Parte. - Agregando elementos y cambiar sus propiedades.

Abramos el programa realbasic, file, y buscas el proyecto: Con open y buscas en las carpetas, o con openrecent que aparecen los últimos proyectos creados sin buscarlos en las carpetas.

Ya que estamos de nuevo creando el proyecto Tux.rbp, recordemos algunas cosas, contiene una ventana y un menú, pero vamos a modificar el proyecto un poco:

La ventana es un elemento, pero a ese elemento podemos agregarle mas elementos.

Agregandole un botón a la ventana:

En la parte izquierda hay varios elementos con un ícono al lado, vamos a escoger el elemento PushButton, doble click y aparece en la ventana, o también se puede arrastrar a la ventana. Al crear este elemento la ventana a la derecha muestra las propiedades de elemento PushButton para que se puedan modificar, pero con solo cliquear la ventana que hay atrás del botón vuelve a mostrar las propiedades de la ventana, en otras palabras, se muestran las propiedades del elemento seleccionado en ese momento.

Puedes cambiar el nombre del elemento PushButton por el que prefieras, ejemplo Botón.

Ahora vamos a cambiar otra propiedad al botón, en este caso el texto que contiene o muestra el botón , para esto luego de escoger el botón, en las propiedades (a la derecha), debajo de Appearance (apariencia), ves caption (que significa título), esta sin título (untitled), pues escogemos la opción y borramos untitled y escribimos ok.




Añadiremos un segundo elemento a la ventana: Texto Estático.

A.- De los elementos que están a la izquierda agregamos StaticText, este será un texto permanente en el programa que vamos a crear, lo usaremos para dar a entender que función tiene el botón que agregamos anteriormente.

B.- Cambio de nombre al nuevo elemento.

Este elemento tiene un nombre, se llama StatickText1 (en la ventana de propiedades,arriba), lo podemos cambiar por otro nombre de elemento, por ejemplo escribimos: Mitexto.

C.- Cambio del texto que muestra el StatickText: En la ventana de propiedades (a la derecha), debajo de appearance aparece text, por defecto aparece untitled, o en otras versiones Label, pero podemos borrarlo y escribir lo que querramos que diga este texto estático o fijo, por ejemplo: HOLA

Este elemento creado se llama Mitexto, y muestra como propiedad Texto la palabra HOLA.

d.- Cambiando la posición del staticktext:

Con el ratón vas a desplazar el ratón hasta la posición 20,30. Esto significa, left=20 y top=30.



Notas:

En una ventana la esquina superior izquierda es el punto 0,0.

El valor Left son los pixeles desde el comienzo de la izquierda de la ventana hacia su derecha.

El valor top son los pixeles desde la parte superior de la ventana hacia abajo de ella.




Así que vamos a llevar el texto fijo a 20 pixeles de la parte izquierda de la ventana, y a 30 pixeles de distancia de la parte superior de la ventana. O si se prefiere en las propiedades del texto se escribe en left 20 y en top 30.

Recordemos que para que aparezcan a la derecha las propiedades del StaticText debe estar seleccionado (click en el texto fijo), de lo contrario apareceran las propiedades del botón si es que está seleccionado, o las de la ventana.




Tercera parte.- Asignarle funciones a los elementos.

Doble click al botón que llamamos botón (Aunque también funciona igual si das doble click a la ventana).

Aparece una nueva ventana (pestaña) con nombre el mismo nombre de la ventana1 (el nombre está en la parte superior), a esta ventana se le llama editor de código o "Code Editor". Sirve para editar código a todos los elemenos (en este caso tres, la ventana, el botón y el texto fijo) que tiene la ventana, no solo al botón al que hicimos doble click.

Ahora tenemos tres pestañas, la pestaña proyect, la pestaña Ventana1 y una segunda pestalla con nombre Ventana1.

Esta nueva ventana tiene dos partes:

A la izquierda los elementos que tiene la ventana (3) y las acciones que pueden realizar (y que podemos asignarle) como ser: Action, Clouse, maximizar, minimizar, etc.

Podemos ver que dice

-Control

- Ok Buton
 Todas acciones que puede realizar
- Aa StaticText1...

Al cliquear el - en Ok Buton se esconden y bajo el aparece Aa StaticText, para volver a ver las propiedades del botón al lado ya no aparece -, si no +, click al + y vuelven a aparecer.

A la derecha aparece la zona de escritura donde escribes el código que prefieras, para esto debe estar seleccionada alguna acción (por ejemplo action) del elemento.

Si seleccionamos la acción Action del botón, vamos a indicarle que acción hará ese botón cuando se pulse por el usuario al usar el programa final.

El programa que vamos a crear hará lo siguiente: Al presionar el botón con el mouse, el texto fijo que dice Hola va a cambiar de posición y de tamaño.

Código del Cambio de la posición del texto:

Como tenemos seleccionado en la ventana del editor de código al botón, y a la acción que va a realizar, en este caso acción. Pues le vamos a agregar un código para que al presionar el botón algo suceda:

El código se escribe jerarquicamente así: Elementomayor.Elementomenor.Propiedad a modificar.

Por ejemplo:

Ventana1.Mitexto.left=100 Ventana1.Mitexto.top=50

En este código jerárquico siempre se separan los elementos con un punto. Primero se menciona el nombre de la Ventana1, y luego el nombre del elemento al que hacemos referencia. Acabamos de hacer dos líneas de código. Esto hara que cuando se pulse el botón, el texto se desplazara a la posición 100, 50. (mas a la derecha y abajo, exactamente 100 pixeles a la derecha y 50 pixeles abajo de la esquina superior izquierda del programa).

Ahora escribimos una tercer línea de código:

Ventana1.Mitexto.TextSize=18.

Esto hara que al presionar el botón el texto Hola se vuelva un poco mas grande.




Extra:

En el lenguaje de programación basic, se usan dos comandos o subrutinas: Sub, y End Sub.

El comando sub indica que se inicia una subrutina.

El comando End Sub indica el final de una subrutina.

El resultado en este lenguaje es:

Sub

Ventana1.Mitexto.left=100

Ventana1.Mitexto.top=50

Ventana1.Mitexto.TextSize=18.

End Sub




Pero como ya seleccionamos Action, no es necesario escribir Sub y End SUb, con escribir unicamente las tres líneas basta:

Ventana1.Mitexto.left=100

Ventana1.Mitexto.top=50

Ventana1.Mitexto.TextSize=18.

Nota: Este código si se puede copiar y pegar al editor de una hoja de texto, o de cualquier lado no hay necesidad de escribirlo línea a línea.

O si prefieres escribirlo:

Empiezas a escribir la primera línea de código de la subrutina: Ventana1.Mitexto.left=100

Luego enter y la siguiente: Ventana1.Mitexto.top=50

Enter y Ventana1.Mitexto.TextSize=18.

Finalmente Enter. Es todo, sin escribir Sub o End Sub en el editor.

Ya terminamos el programa. A salvarlo para que no se pierda: File, save, o simplemente Ctrl + S.




Cuarta Parte: Corrección de la Sintaxis y Construcción del programa para linux, windows y mac.

Corrección de la sintaxis

Veremos si es que se cometió algún error al hacer el programa, si no nos equivocamos en la sintaxis, si al escribir el código nombramos mal algun elemento, o no cambiamos el nombre al elemento, etc.

Cerramos la ventana (pestaña) editor (la última), también llamada Ventana1 (el mismo nombre que el de la ventana), y click a Run (el botón verde), si dice que hay bug esta malo y muestra el error, en cambio si muestra el programa funcionando esta bien escrito. También puedes ir a project, run, o simplemente Ctrl + R.

Lo mas seguro es que está bien, pero siempre puede haber algún error.


Construcción del programa, para linux, windows o mac.

Sencillamente click al botón Build, o también Project, Build Application, o simplemente Ctrl B y listo, programa listo para usar. El archivo se llama Myaplicaton.

Si quieres cambiar a que sistema operativo construiras el programa:

Project, Build Settings, o Ctrl+Shift+B.

Aparece una ventana y escoges Windows 2000 o superior, Linux 2.x, Mac X. Uno o todos. Y el lenguaje, por ejemplo Spanish. Finalmente Ok para que quede esta opción, o Build para construirlo.

Se llamara Myapplication sin extensión si es para linux, Myapplication.exe si exportastes a windows y Myapplication.app.tar si exportastes para Mac OS X.




Quinta Parte - Modificando el proyecto y programa realizado.

Primero daremos otro nombre al proyecto actual (para que el anterior no se modifique): File, save as, le das otro nombre, por ejemplo Tuxb.rbp y escoges la carpeta donde lo guardarás.

Click a la ventana y le añadimos otro PushButton, lo movemos con el mouse donde querramos.

Como este botón nuevo esta seleccionado, le cambiamos las propiedades (en la columna derecha) igual que con el botón anterior.

Name: CerrarVentana (así lo llamaremos). Caption: Fin

Luego doble click al botón CerrarVentana y aparece el editor de código (igual que ene el caso anterior ya aparece seleccionado el evento action), escribir este código:

quit

Es todo, ese es un comando de basic que indica que el programa se cerrará o finalizará, en este caso al pulsar el botón cerrar ventana y que tiene dentro del botón un título que dice Fin.




Esta subrutina quedaria así:

Sub

quit

End Sub

No hay que escribir esto, solo se menciona para comentar como quedaria.




Cerramos este editor de código (la pestaña), y doble click al botón "botón", y agregamos esta línea de código:

Ventana1.MiTexto.text= "ADIOS"

Luego en las propiedades del botón "botón", marcamos la casilla default (en Appearance), esto para que el botón quede seleccionado por defecto (al abrir el programa).

Salvamos el proyecto y construimos el programa para el sistema operativo que querramos. El programa funciona así, click al botón "botón" que tiene texto OK, y el texto dirá adios, click al botón "CerrarVentana" que tiene texto Fin y se cierra el programa.




Referencia