Kdenlive/Obtener e instalar

Kdenlive se puede instalar en los más recientes sistemas GNU/Linux y FreeBSD, tanto en arquitecturas x86 como AMD64 (aunque pueden aparecer problemas ejecutándolo en AMD64 sobre Debian/Ubuntu - por verificar -). La instalación se puede realizar a partir del código fuente o a partir de los paquetes binarios existentes para un buen número de distribuciones.

Instalando Kdenlive desde paquetes binariosEditar

Muchas distros ya ofrecen Kdenlive como un programa estándar. Para poder utilizarlo en tu sistema, debes asegurarte de disponer de los otros paquetes de los cuales depende:

En la mayoría de distribuciones, el software necesario se instalara automáticamente al instalar Kdenlive. Si no fuese así, Kdenlive te avisará del software que falta cuando lo necesite. Si esto ocurre, simplemente cierra Kdenlive, instala el paquete que falta y vuelve a arrancar Kdenlive.

Ark LinuxEditar

Ark Linux incluye Kdenlive y los demás programas necesarios. Simplemente ejecuta

apt-get install kdenlive

O selecciona kdenlive en el Control de Misión -> Instalar Software.

Debian Sid/EtchEditar

Los paquetes binarios para Debian han sido compilados por Christian Marillat.

Añade la siguiente línea al fichero /etc/apt/sources.list:

Para Sid:

deb http://www.debian-multimedia.org sid main

Para Testing (en estos momentos Lenny):

deb http://www.debian-multimedia.org testing main

Necesitaras previamente haber importado las claves de Marillat:

gpg --keyserver pgp.mit.edu --recv-keys 1F41B907
gpg --armor --export 1F41B907 > key.asc
sudo apt-key add key.asc

Y para instalarlo, teclea

sudo apt-get update ; sudo apt-get install kdenlive

El instalador de Debian cargará la última versión disponible de Kdenlive (en estos momentos 0.5) y las librerías y programas necesarios.

UbuntuEditar

Los usuarios de Gutsy (Ubuntu 7.10) pueden cargar directamente Kdenlive version 7.3 desde los repositorios Universe. Simplemente busca el programa en Synaptic o teclea desde el terminal:

sudo apt-get update ; sudo apt-get install kdenlive

Versiones mas actualizadas pueden encontrarse en el repositorio no oficial de Treviño ([1]), aunque se han reportado algunos problemas trabajando con estas versiones en Gutsy y Feisty.

Nota: Si al instalar el paquete de Treviño se recibe un error la primera vez que ejecutamos Kdenlive del tipo "Cannot find your MLT installation, please give the path" ("No se puede encontrar la instalación de MLT, por favor indique la ruta"), simplemente deberemos aceptar la que ya nos aparece por defecto y Kdenlive arrancará sin problemas.

Paquetes para AMD64 están disponibles desde Repositorio uPure64.

RedHat/FedoraEditar

RPMs for Fedora Core 6 can be downloaded from this page:

kdenlive and mlt

Unfortunately it's my very first packaging effort, so use them with caution.

Install the above dependencies using yum or apt:

yum install ffmpeg xine dvdauthor dvgrab kdebase 

After downloading rpms, we suppose rpms to be in /tmp, install with:

cd /tmp
rpm -Uvh kdenlive*.rpm mlt*.rpm

Good luck!

...Anyway, you may try to install the Mandriva RPM indicated below...

MandrivaEditar

You can install kdenlive 0.5 (i686/MMX) in Mandriva 2007 installing the following 4 packages backported from cooker :

The source RPMS are there :


Starting from Mandriva 2008.0, kdenlive 0.5 (i586/no MMX) is available directly in the distro, and can be installed using the control center.

GentooEditar

Gentoo users can simply install kdenlive using emerge. (0.4 is available in portage since april 2007, 0.5 will come out soon).

First, if you haven't synced your portage tree for a long time, do

emerge --sync

Then, since some dependencies (and kdenlive itself) are masked with the "testing"-keyword,

nano -w /etc/portage/package.keywords

and add the following lines (adjust to your architecture):

media-libs/mlt ~x86
media-libs/mlt++ ~x86
media-video/dvgrab ~x86
media-video/kdenlive ~x86

Now you can simply

emerge -av kdenlive

This will currently install 0.4. If you don't want to wait for the 0.5-ebuild, you can flawlessly install 0.5 from the sources; as of August 30, all the dependencies will be met with the above steps.


Slackware 12.0Editar

Slackware packages for KDEnlive and all required libraries are available at the slacky.eu repositories [2] in the /multimedia and /libraries directories.

SuSEEditar

Suse packages for MLT 0.2.4 and Kdenlive 0.5 are available from the packman project:

http://packman.links2linux.de/package/kdenlive

PardusEditar

Pardus PiSi package of Kdenlive 0.4 is ready to install via Package Manager. You can type "kdenlive "in the search bar and click install button or you can install it from console.

sudo pisi it kdenlive

If you want, you can compile Kdenlive from the svn repository, too.

sudo pisi build http://svn.pardus.org.tr/pardus/2007/desktop/kde/kdenlive/pspec.xml

and

sudo pisi it kdenlive*.pisi

Compilando desde código fuenteEditar

Instalando desde SVNEditar

¡¡¡Asegurese de instalar todas las bibliotecas de la lista antes de intentar compilar Kdenlive!!!

Instale las bibliotecas en el orden en que están listadas en esta página. Muchas bibliotecas y ficheros de cabeceras posiblemente estén disponibles como paquetes auto-instalables en su distribución GNU/Linux.-

Requerimientos :

  • Archivos de desarrollo de QT y KDE (KDE >= 3.4 requerido)

Disponibles en la mayoría de las distribuciones (normalmente los encontrará como qt-devel y kdelibs-devel). Para usuarios de Debian, consulte debian-desktop.org para verificar las versiones más recientes de KDE.

  • SDL

Paquete existente en la mayoría de las distribuciones. Instale los paquetes de desarrollo: SDL-dev y SDL-image-dev.

  • Audio / vídeo y otras bibliotecas (Debería poder encontrar paquetes binarios para todos ellos en su distribución):
    • Gdk-Pixbuf (gdk-pixbuf, gdk-pixbuf-dev) (ya no es necesario)
    • libsamplerate (libsamplerate, libsamplerate-dev)
    • OGG (libogg, libogg-dev)
    • Vorbis (libvorbis, libvorbis-dev)
    • libdv (libdv, libdv-dev)
    • Ladspa (ladspa-sdk)
    • libJack (libjack-dev)
    • Ladspa plugins (swh-plugins)
    • SOX (sox, sox-dev)
    • libXML2 (libxml2, libxml2-dev)
    • libmad (libmad-dev)
  • Opcional:
    • Libquicktime (libquicktime, libquicktime-dev)
    • Theora (libtheora, libtheora-dev)
  • FFMPEG (archivos de desarrollo de libavformat, versión reciente + libswscale, libswscale-dev):

Si no puede encontrar paquetes recientes para libavformat-dev o libswcale-dev (los usuarios de Ubuntu pueden intentarlo en http://ubuntu.tonio.homelinux.org), descargue la versión de desarrollo svn:

svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg

Las opciones de configuración recomendadas para ffmpeg son:

./configure --enable-gpl --enable-shared --enable-libvorbis --enable-libogg --enable-pp --enable-swscaler


mlt 0.2.4 stable release is required for Kdenlive 0.5.

You can install mlt 0.2.4 or checkout MLT from SVN:

svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt mlt

Recommended config option for MLT:

./configure --prefix=/usr --enable-gpl --disable-mmx --avformat-swscale --enable-motion-est

All other MLT configure options are enabled by default.

You might need --avformat-ldextra if your ffmpeg/libavcodec is built against some external libs like libmp3lame or libvorbis. My ld.so does not require this, but it seems some systems/environments require it.

NOTE 1:Make sure that the configure output gives no error for modules/avformat, since it means FFMpeg was not correctly installed. Make sure swh-plugins and ladspa-sdk packages are installed. These packages provide sound effects. MLT has many dependencies, but you will be warned at ./configure time

NOTE 2: When you are on (K)Ubuntu and the ./configure... step ends in errors like:
./configure: 37: function: not found
./configure: 93: function: not found
./configure: 174: build_config: not found
...
./configure: 191: build_pkgconfig: not found

Either edit the ./configure file and replace on the first line "#!/bin/sh" to "#!/bin/bash" and run again, or simply type: bash ./configure ..... This problem is caused due to the fact that (K)Ubuntu Edgy defaults to the dash shell instead of the bash shell. Dash is currently known for being less compatible with scripting.


Checkout MLT++ from SVN:

svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt++ mlt++

Debian UnstableEditar

Debian binary packages are provided by Christian Marillat. Packages include the latest ffmpeg developments are usually very well up-to-date. For example, mlt includes kdenlive module and avformat-swscale.

Add the following line to your /etc/apt/sources.list file:

# Experimental
deb http://www.debian-multimedia.org experimental main
deb-src http://www.debian-multimedia.org experimental main
# Unstable
deb http://www.debian-multimedia.org sid main
deb-src http://www.debian-multimedia.org sid main
# Testing
deb http://www.debian-multimedia.org testing main
deb-src http://www.debian-multimedia.org testing main

If you haven't done so yet, import Marillat's key:

gpg --keyserver pgp.mit.edu --recv-keys 1F41B907
gpg --armor --export 1F41B907 > key.asc
sudo apt-key add key.asc

Then, simply type sudo apt-get build-dep kdenlive

When compiling Kdenlive 0.5 svn from source, you will also need: sudo apt-get install mlt libmlt0.2.3 libmlt-dev libmlt++0.2.3 libmlt++-dev


Instalación en Ubuntu GutsyEditar

1) Install from Synaptic the following packages

qt4-dev-tools, kdelibs4-dev, libsdl1.2-dev, libsdl-image1.2-dev, libsamplerate0, libsamplerate0-dev, libdv4-dev, ladspa-sdk, libjack-dev, swh-plugins, sox, sox-dev, libmad0-dev, subversion, libgsm1-dev, autotools-dev, g++, automake1.9, autoconf.

Some other packs are needed but, or are already installed by default in Ubuntu or are dependencies of the previous ones and are automatically installed by Synaptic.

2) Open a session in the root terminal and goto to /usr/src (maybe it works also in other directories, but that's where I went !)

cd /usr/src

3) Get and install FFMPEG

svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg

cd ffmpeg

./configure --enable-gpl --enable-shared --enable-libvorbis --enable-libogg --enable-pp --enable-swscaler

make

make install

cd ..

4) Get and install MLT and MLT++

svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt mlt

cd mlt

./configure --enable-gpl --disable-mmx --avformat-swscale --enable-motion-est

make

make install

cd ..

svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt++ mlt++

cd mlt++

./configure

make

make install

cd ..

(to be honest, I' using mlt version 0.2.4, not the last svn version but I think that will not be a problem. In any case, if you want to be sure download the tar file for version 0.2.4 from sourceforge, copy to /usr/src, extract it and you'll get the directory mlt-0.2.4. Then cd to this directory and configure, make and install as previously stated)

5) Get and install kdenlive

svn co https://kdenlive.svn.sourceforge.net/sv ... k/kdenlive kdenlive

cd kdenlive

sh bootstrap

./configure --enable-debug=full

make (it takes soooooooome time)

make install

cd ..

Compiling kdenliveEditar

Checkout Kdenlive from SVN:

svn co https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive kdenlive

NOTE: Once you have dowloaded the complete svn package, you can update your local svn source by only downloading the updated parts. Say you have downloaded the svn into ~/kdenlive. Simply cd into ~/kdenlive and type: svn update.


Configure Kdenlive with full debug support, compile and install:

cd kdenlive ; \
sh bootstrap ;\
./configure --prefix=/usr --enable-debug=full; \
unsermake ; \
sudo unsermake install

You are now ready to use Kdenlive!

Compilar conjuntamente kdenlive, ffmpeg y mlt - la forma más fácilEditar

La mejor opción para probadores y usuarios interesados es obtener las versiones actualizadas de ffmpeg, mlt y kdenlive. Puesto que no es una tarea sencilla, hemos creado un programa de lotes que hara este trabajo por ti.

Puedes bajar la versión actualizada de este programa desde el foro de kdenlive:

Descargalo, guárdalo en tu directorio de fuentes (/home/espinosa/src por ejemplo), renombralo como kdenlive_builder.sh (preferentemente), hazlo ejecutable, sitúate en el directorio donde lo has guardado y ejecuta :

 ./bash kdenlive_builder.sh

Se mostrara un menú de XDialog.

Escoge la primera opción (GET) para limpiar (make clean) instalaciones previas y descargar nuevas fuentes de los programas desde SVN. El programa preguntara por un directorio donde guardar dichas fuentes.

Escoge la segunda opción (INSTALL) para compilar e instalar las fuentes que previamente has descargado. El programa nos solicitara el directorio donde se encuentran las fuentes y el directorio donde queremos instalar el programa. Si escogemos /usr, se nos mostrará un mensaje de aviso y, durante la instalación, se solicitara el password de root. Esto no ocurrirá si seleccionamos para la instalación un subdirectorio en nuestro directorio personal (/home). Durante la instalación indicaremos si deseamos compilar kdenlive con soporte para diferentes codecs de audio/vídeo no estándares. Si escogemos alguno de ellos, deberemos asegurarnos de haber instalado previamente las librerías necesarias.

Escoge la tercera opción (FULL) para ejecutar los dos pasos anteriores (GET e INSTALL) al mismo tiempo.

Escoge la cuarta opción (INFO) para obtener información sobre las versiones SVN de los programas descargados.

Una vez compilados e instalados los programas deberás ejecutar kdenlive desde el directorio de instalación seleccionado.

Este programa es especialmente útil para probadores, ya que permite disponer de multiples versiones instaladas del programa en diferentes directorios (home, usr, local, ...) cada una de ellas con sus versiones correspondientes de ffmpeg and mlt. Además, con este programa nos aseguramos de disponer siempre de las versiones actualizadas de todos los programas y librerías, evitando problemas por intentar ejecutar kdenlive con versiones no actualizadas de ffmpeg o mlt.

Si tienes problemas al instalar o ejecutar el programa, busca primero la solución en el foro de kdenlive o, si no la encuentras, deja allí tu consulta.

NOTA: Este programa no verifica la instalación previa de otras librerías necesarias para ejecutar kdenlive, como SDL, liblame, libx264 etc. Lee detenidamente la sección de requerimientos para asegurar que están todas instaladas (paquetes -dev o fuentes)